What’s Vulnerable › Vulnerabilities
CVE-2023-32711: Persistent Cross-Site Scripting (XSS) through a URL Validation Bypass within a Dashboard View
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-01 · updated 2026-06-17
- Weakness: CWE-79
Description
In Splunk Enterprise versions below 9.0.5, 8.2.11, and 8.1.14, a Splunk dashboard view lets a low-privileged user exploit a vulnerability in the Bootstrap web framework (CVE-2019-8331) and build a stored cross-site scripting (XSS) payload.
Affected products
- Splunk Enterprise: from 8.1.0 before 8.1.14; from 8.2.0 before 8.2.11; from 9.0.0 before 9.0.5 — fixed in 8.1.14, 8.2.11, 9.0.5
How to fix
Upgrade to a fixed version: Splunk Enterprise 8.1.14, 8.2.11, 9.0.5. Check the vendor advisory for mitigations.
References
- https://advisory.splunk.com/advisories/SVD-2023-0605
- https://research.splunk.com/application/8a43558f-a53c-4ee4-86c1-30b1e8ef3606/
- https://advisory.splunk.com/advisories/SVD-2023-0605
- https://research.splunk.com/application/8a43558f-a53c-4ee4-86c1-30b1e8ef3606/
Get alerted when CVE-2023-32711 or the next vulnerability affects your stack