What’s Vulnerable › Vulnerabilities
CVE-2023-32715: Self Cross-Site Scripting (XSS) on Splunk App for Lookup File Editing
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-01 · updated 2026-06-17
- Weakness: CWE-79
Description
In the Splunk App for Lookup File Editing versions below 4.0.1, a user can insert potentially malicious JavaScript code into the app, which causes that code to run on the user’s machine. The app itself does not contain the potentially malicious JavaScript code. The vulnerability requires the attacker to phish the victim by tricking them into initiating a request within their browser, and requires additional user interaction to trigger. The attacker cannot exploit the vulnerability at will.
Affected products
- Splunk App for Lookup File Editing: before 4.0.1 — fixed in 4.0.1
How to fix
Upgrade to a fixed version: Splunk App for Lookup File Editing 4.0.1. Check the vendor advisory for mitigations.
References
- https://advisory.splunk.com/advisories/SVD-2023-0610
- https://advisory.splunk.com/advisories/SVD-2023-0610
Get alerted when CVE-2023-32715 or the next vulnerability affects your stack