What’s Vulnerable › Vulnerabilities
CVE-2023-32731: Information leak in gRPC
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-09 · updated 2026-06-17
- Weakness: CWE-440
Description
When gRPC HTTP2 stack raised a header size exceeded error, it skipped parsing the rest of the HPACK frame. This caused any HPACK table mutations to also be skipped, resulting in a desynchronization of HPACK tables between sender and receiver. If leveraged, say, between a proxy and a backend, this could lead to requests from the proxy being interpreted as containing headers from different proxy clients - leading to an information leak that can be used for privilege escalation or data exfiltration. We recommend upgrading beyond the commit contained in https://github.com/grpc/grpc/pull/33005 https://github.com/grpc/grpc/pull/33005
Affected products
- Google gRPC: from 1.53.0 before 1.55.0 — fixed in 1.55.0
How to fix
Upgrade to a fixed version: Google gRPC 1.55.0. Check the vendor advisory for mitigations.
References
- https://github.com/grpc/grpc/pull/32309
- https://github.com/grpc/grpc/pull/33005
- https://github.com/grpc/grpc/pull/32309
- https://github.com/grpc/grpc/pull/33005
Get alerted when CVE-2023-32731 or the next vulnerability affects your stack