What’s Vulnerable › Vulnerabilities
CVE-2023-32762
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-28 · updated 2026-06-17
Description
An issue was discovered in Qt before 5.15.14, 6.x before 6.2.9, and 6.3.x through 6.5.x before 6.5.1. Qt Network incorrectly parses the strict-transport-security (HSTS) header, allowing unencrypted connections to be established, even when explicitly prohibited by the server. This happens if the case used for this header does not exactly match.
Affected products
- Debian Linux: 10.0
- Qt: from 5.9.0 before 5.15.14; from 6.0.0 before 6.2.9; from 6.3.0 before 6.5.1 — fixed in 5.15.14, 6.2.9, 6.5.1
How to fix
Upgrade to a fixed version: Qt 5.15.14, 6.2.9, 6.5.1. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/qtbase/+/476140
- https://github.com/qt/qtbase/commit/1b736a815be0222f4b24289cf17575fc15707305
- https://lists.debian.org/debian-lts-announce/2024/04/msg00027.html
- https://lists.qt-project.org/pipermail/announce/2023-May/000414.html
- https://codereview.qt-project.org/c/qt/qtbase/+/476140
- https://github.com/qt/qtbase/commit/1b736a815be0222f4b24289cf17575fc15707305
- https://lists.debian.org/debian-lts-announce/2024/04/msg00027.html
- https://lists.qt-project.org/pipermail/announce/2023-May/000414.html
Get alerted when CVE-2023-32762 or the next vulnerability affects your stack