What’s Vulnerable › Vulnerabilities
CVE-2023-32763
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-28 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in Qt before 5.15.15, 6.x before 6.2.9, and 6.3.x through 6.5.x before 6.5.1. When a SVG file with an image inside it is rendered, a QTextLayout buffer overflow can be triggered.
Affected products
- Qt: before 5.15.15; from 6.0.0 before 6.2.9; from 6.3.0 before 6.5.1 — fixed in 5.15.15, 6.2.9, 6.5.1
How to fix
Upgrade to a fixed version: Qt 5.15.15, 6.2.9, 6.5.1. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/qtbase/+/476125
- https://lists.debian.org/debian-lts-announce/2023/08/msg00028.html
- https://lists.debian.org/debian-lts-announce/2024/04/msg00027.html
- https://lists.qt-project.org/pipermail/announce/2023-May/000413.html
- https://security.gentoo.org/glsa/202402-03
- https://codereview.qt-project.org/c/qt/qtbase/+/476125
- https://lists.debian.org/debian-lts-announce/2023/08/msg00028.html
- https://lists.debian.org/debian-lts-announce/2024/04/msg00027.html
- https://lists.qt-project.org/pipermail/announce/2023-May/000413.html
- https://security.gentoo.org/glsa/202402-03
Get alerted when CVE-2023-32763 or the next vulnerability affects your stack