What’s Vulnerable › Vulnerabilities
CVE-2023-32803
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-14 · updated 2026-09-22
- Weakness: CWE-669
Description
The ca-certificates package before ca-certificates-2021.2.50-72 for Amazon Linux 2 (AL2) does not properly remove certain TrustCor root certificates from the root store. NOTE: this issue exists because of an incorrect fix for CVE-2022-23491.
Affected products
- Amazon ca-certificates: before 2021.2.50-72 — fixed in 2021.2.50-72
How to fix
Upgrade to a fixed version: Amazon ca-certificates 2021.2.50-72. Check the vendor advisory for mitigations.
References
- https://alas.aws.amazon.com/AL2/ALAS-2023-1957.html
- https://explore.alas.aws.amazon.com/CVE-2023-32803.html
Get alerted when CVE-2023-32803 or the next vulnerability affects your stack