What’s Vulnerable › Vulnerabilities
CVE-2023-3288: A BOLA vulnerability in POST /providers in EasyAppointments < 1.5.0
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-639
Description
A BOLA vulnerability in POST /providers allows a low privileged user to create a privileged user (provider) in the system. This results in privilege escalation.
Affected products
- alextselegidis/easyappointments: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: alextselegidis/easyappointments 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/alextselegidis/easyappointments
- https://github.com/alextselegidis/easyappointments
Get alerted when CVE-2023-3288 or the next vulnerability affects your stack