What’s Vulnerable › Vulnerabilities
CVE-2023-3291: Heap-based Buffer Overflow in gpac/gpac
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-16 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.2.2.
Affected products
- GPAC: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: GPAC 2.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/6a748ccc3f76ff10e3ae43014967ea4b0c088aaf
- https://huntr.dev/bounties/526954e6-8683-4697-bfa2-886c3204a1d5
- https://www.debian.org/security/2023/dsa-5452
- https://github.com/gpac/gpac/commit/6a748ccc3f76ff10e3ae43014967ea4b0c088aaf
- https://huntr.dev/bounties/526954e6-8683-4697-bfa2-886c3204a1d5
- https://www.debian.org/security/2023/dsa-5452
Get alerted when CVE-2023-3291 or the next vulnerability affects your stack