What’s Vulnerable › Vulnerabilities
CVE-2023-32956
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-16 · updated 2026-06-17
Description
Improper neutralization of special elements used in an OS command ('OS Command Injection') vulnerability in CGI component in Synology Router Manager (SRM) before 1.2.5-8227-6 and 1.3.1-9346-3 allows remote attackers to execute arbitrary code via unspecified vectors.
Affected products
- Synology Router Manager (SRM): from 1.2 before 1.2.5-8227-6; from 1.3 before 1.3.1-9346-3 — fixed in 1.2.5-8227-6, 1.3.1-9346-3
How to fix
Upgrade to a fixed version: Synology Router Manager (SRM) 1.2.5-8227-6, 1.3.1-9346-3. Check the vendor advisory for mitigations.
References
- https://www.synology.com/en-global/security/advisory/Synology_SA_22_25
- https://www.synology.com/en-global/security/advisory/Synology_SA_22_25
Get alerted when CVE-2023-32956 or the next vulnerability affects your stack