What’s Vulnerable › Vulnerabilities
CVE-2023-3297
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-01 · updated 2026-06-17
- Weakness: CWE-416
Description
In Ubuntu's accountsservice an unprivileged local attacker can trigger a use-after-free vulnerability in accountsservice by sending a D-Bus message to the accounts-daemon process.
Affected products
- Canonical accountsservice: before 23.13.9-2ubuntu2; before 22.08.8-1ubuntu7.1; before 22.07.5-2ubuntu1.4; before 0.6.55-0ubuntu12\~20.04.6 — fixed in 0.6.55-0ubuntu12\~20.04.6, 22.07.5-2ubuntu1.4, 22.08.8-1ubuntu7.1, 23.13.9-2ubuntu2
- Canonical Ubuntu Linux: 20.04, 22.04, 22.10, 23.04
How to fix
Upgrade to a fixed version: Canonical accountsservice 0.6.55-0ubuntu12\~20.04.6, 22.07.5-2ubuntu1.4, 22.08.8-1ubuntu7.1, 23.13.9-2ubuntu2. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/2024182
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-3297
- https://securitylab.github.com/advisories/GHSL-2023-139_accountsservice/
- https://ubuntu.com/security/notices/USN-6190-1
- https://bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/2024182
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-3297
- https://securitylab.github.com/advisories/GHSL-2023-139_accountsservice/
- https://ubuntu.com/security/notices/USN-6190-1
Get alerted when CVE-2023-3297 or the next vulnerability affects your stack