What’s Vulnerable › Vulnerabilities
CVE-2023-32971: QTS, QuTS hero, QuTScloud
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-06 · updated 2026-06-17
- Weakness: CWE-120
Description
A buffer copy without checking size of input vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow authenticated administrators to execute code via a network. We have already fixed the vulnerability in the following versions: QTS 5.0.1.2425 build 20230609 and later QTS 5.1.0.2444 build 20230629 and later QTS 4.5.4.2467 build 20230718 and later QuTS hero h5.0.1.2515 build 20230907 and later QuTS hero h5.1.0.2424 build 20230609 and later QuTS hero h4.5.4.2476 build 20230728 and later QuTScloud c5.1.0.2498 and later
Affected products
- QNAP QTS: from 4.5.0 before 4.5.4.2467; from 5.0.0 before 5.0.1.2425; from 5.1.0 before 5.1.0.2444 — fixed in 4.5.4.2467, 5.0.1.2425, 5.1.0.2444
- QNAP Systems Inc. QuTS hero: from h4.5.0 before h4.5.4.2476; from h5.0.0 before h5.0.1.2515; from h5.1.0 before h5.1.0.2424 — fixed in h4.5.4.2476, h5.0.1.2515, h5.1.0.2424
- QNAP Systems Inc. QuTScloud: from c5.0.1 before c5.1.0.2498 — fixed in c5.1.0.2498
How to fix
Upgrade to a fixed version: QNAP QTS 4.5.4.2467, 5.0.1.2425, 5.1.0.2444; QNAP Systems Inc. QuTS hero h4.5.4.2476, h5.0.1.2515, h5.1.0.2424; QNAP Systems Inc. QuTScloud c5.1.0.2498. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-23-37
- https://www.qnap.com/en/security-advisory/qsa-23-37
Get alerted when CVE-2023-32971 or the next vulnerability affects your stack