What’s Vulnerable › Vulnerabilities
CVE-2023-32974: QTS, QuTS hero, QuTScloud
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-13 · updated 2026-06-17
- Weakness: CWE-22
Description
A path traversal vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow users to read the contents of unexpected files and expose sensitive data via a network. We have already fixed the vulnerability in the following versions: QTS 5.1.0.2444 build 20230629 and later QuTS hero h5.1.0.2424 build 20230609 and later QuTScloud c5.1.0.2498 and later
Affected products
- QNAP QTS: from 5.1.0 before 5.1.0.2444 — fixed in 5.1.0.2444
- QNAP Systems Inc. QuTS hero: from h5.1.0 before h5.1.0.2424 — fixed in h5.1.0.2424
- QNAP Systems Inc. QuTScloud: from c5.0.0.1919 before c5.1.0.2498 — fixed in c5.1.0.2498
How to fix
Upgrade to a fixed version: QNAP QTS 5.1.0.2444; QNAP Systems Inc. QuTS hero h5.1.0.2424; QNAP Systems Inc. QuTScloud c5.1.0.2498. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-23-42
- https://www.qnap.com/en/security-advisory/qsa-23-42
Get alerted when CVE-2023-32974 or the next vulnerability affects your stack