What’s Vulnerable › Vulnerabilities
CVE-2023-33010: Zyxel Multiple Firewalls Buffer Overflow Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-06-05
- EPSS: 29.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-24 · updated 2026-06-17
- Weakness: CWE-120
Description
A buffer overflow vulnerability in the ID processing function in Zyxel ATP series firmware versions 4.32 through 5.36 Patch 1, USG FLEX series firmware versions 4.50 through 5.36 Patch 1, USG FLEX 50(W) firmware versions 4.25 through 5.36 Patch 1, USG20(W)-VPN firmware versions 4.25 through 5.36 Patch 1, VPN series firmware versions 4.30 through 5.36 Patch 1, ZyWALL/USG series firmware versions 4.25 through 4.73 Patch 1, could allow an unauthenticated attacker to cause denial-of-service (DoS) conditions and even a remote code execution on an affected device.
Affected products
- Zyxel Atp100 Firmware: from 4.32 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Atp100W Firmware: from 4.32 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Atp200 Firmware: from 4.32 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Atp500 Firmware: from 4.32 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Atp700 Firmware: from 4.32 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Atp800 Firmware: from 4.32 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Usg20-Vpn Firmware: from 4.30 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel USG 20(W)-VPN firmware: 5.36, 5.36-patch1
- Zyxel Usg 40 Firmware: from 4.25 before 4.73; 4.73, 4.73-patch1 — fixed in 4.73
- Zyxel Usg 40W Firmware: from 4.25 before 4.73; 4.73, 4.73-patch1 — fixed in 4.73
- Zyxel Usg 60 Firmware: from 4.25 before 4.73; 4.73, 4.73-patch1 — fixed in 4.73
- Zyxel Usg 60W Firmware: from 4.25 before 4.73; 4.73, 4.73-patch1 — fixed in 4.73
- Zyxel firewall (ZLD): from 4.50 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel USG FLEX 100(W) firmware: 5.36, 5.36-patch1
- Zyxel USG FLEX 200 firmware: from 4.50 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel USG FLEX 500 firmware: from 4.50 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Usg Flex 50 Firmware: 5.36, 5.36-patch1
- Zyxel USG FLEX 50(W) firmware: from 4.25 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel USG FLEX 700 firmware: from 4.50 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Vpn1000 Firmware: from 4.30 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Vpn100 Firmware: from 4.30 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Vpn300 Firmware: from 4.30 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
- Zyxel Vpn50 Firmware: from 4.30 before 5.36; 5.36, 5.36-patch1 — fixed in 5.36
How to fix
Upgrade to a fixed version: Zyxel Atp100 Firmware 5.36; Zyxel Atp100W Firmware 5.36; Zyxel Atp200 Firmware 5.36; Zyxel Atp500 Firmware 5.36; Zyxel Atp700 Firmware 5.36; Zyxel Atp800 Firmware 5.36; Zyxel Usg20-Vpn Firmware 5.36; Zyxel Usg 40 Firmware 4.73; Zyxel Usg 40W Firmware 4.73; Zyxel Usg 60 Firmware 4.73; Zyxel Usg 60W Firmware 4.73; Zyxel firewall (ZLD) 5.36. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-multiple-buffer-overflow-vulnerabilities-of-firewalls
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-multiple-buffer-overflow-vulnerabilities-of-firewalls
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-33010
Get alerted when CVE-2023-33010 or the next vulnerability affects your stack