What’s Vulnerable › Vulnerabilities
CVE-2023-3312
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-19 · updated 2026-06-17
- Weakness: CWE-415
Description
A vulnerability was found in drivers/cpufreq/qcom-cpufreq-hw.c in cpufreq subsystem in the Linux Kernel. This flaw, during device unbind will lead to double release problem leading to denial of service.
Affected products
- Linux kernel: from 6.2 before 6.2.15; from 6.3 before 6.3.2 — fixed in 6.2.15, 6.3.2
How to fix
Upgrade to a fixed version: Linux kernel 6.2.15, 6.3.2. Check the vendor advisory for mitigations.
References
- https://patchwork.kernel.org/project/linux-pm/patch/20230323174026.950622-1-krzysztof.kozlowski%40linaro.org/
- https://security.netapp.com/advisory/ntap-20230731-0005/
- https://patchwork.kernel.org/project/linux-pm/patch/20230323174026.950622-1-krzysztof.kozlowski%40linaro.org/
- https://security.netapp.com/advisory/ntap-20230731-0005/
Get alerted when CVE-2023-3312 or the next vulnerability affects your stack