What’s Vulnerable › Vulnerabilities
CVE-2023-33127: .NET and Visual Studio Elevation of Privilege Vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-11 · updated 2026-06-17
- Weakness: CWE-1220
Description
.NET and Visual Studio Elevation of Privilege Vulnerability
Affected products
- Microsoft .NET: from 6.0.0 before 6.0.20; from 7.0.0 before 7.0.9 — fixed in 6.0.20, 7.0.9
- Microsoft Visual Studio 2022 version 17.14: from 17.0 before 17.0.23; from 17.2.0 before 17.2.17; from 17.4.0 before 17.4.9; from 17.6.0 before 17.6.5; 17.3 — fixed in 17.0.23, 17.2.17, 17.4.9, 17.6.5
- Microsoft .NET 6.0: from 6.0.0 before 6.0.20 — fixed in 6.0.20
- Microsoft .NET 7.0: from 7.0.0 before 7.0.9 — fixed in 7.0.9
- Microsoft Visual Studio 2022 version 17.0: from 17.0.0 before 17.0.23 — fixed in 17.0.23
- Microsoft Visual Studio 2022 version 17.2: from 17.2.0 before 17.2.17 — fixed in 17.2.17
- Microsoft Visual Studio 2022 version 17.4: from 17.4.0 before 17.4.9 — fixed in 17.4.9
- Microsoft Visual Studio 2022 version 17.6: from 17.6.0 before 17.6.5 — fixed in 17.6.5
- Microsoft PowerShell 7.2: from 7.2.0 before 7.2.13 — fixed in 7.2.13
- Microsoft PowerShell 7.3: from 7.3.0 before 7.3.6 — fixed in 7.3.6
How to fix
Upgrade to a fixed version: Microsoft .NET 6.0.20, 7.0.9; Microsoft Visual Studio 2022 version 17.14 17.0.23, 17.2.17, 17.4.9, 17.6.5; Microsoft .NET 6.0 6.0.20; Microsoft .NET 7.0 7.0.9; Microsoft Visual Studio 2022 version 17.0 17.0.23; Microsoft Visual Studio 2022 version 17.2 17.2.17; Microsoft Visual Studio 2022 version 17.4 17.4.9; Microsoft Visual Studio 2022 version 17.6 17.6.5; Microsoft PowerShell 7.2 7.2.13; Microsoft PowerShell 7.3 7.3.6. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-33127
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-33127
Get alerted when CVE-2023-33127 or the next vulnerability affects your stack