What’s Vulnerable › Vulnerabilities
CVE-2023-33177: Xibo CMS vulnerable to Remote Code Execution through Zip Slip
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-30 · updated 2026-06-17
- Weakness: CWE-22
Description
Xibo is a content management system (CMS). A path traversal vulnerability exists in the Xibo CMS whereby a specially crafted zip file can be uploaded to the CMS via the layout import function by an authenticated user which would allow creation of files outside of the CMS library directory as the webserver user. This can be used to upload a PHP webshell inside the web root directory and achieve remote code execution as the webserver user. Users should upgrade to version 2.3.17 or 3.3.5, which fix this issue. Customers who host their CMS with Xibo Signage have already received an upgrade or patch to resolve this issue regardless of the CMS version that they are running.
Affected products
- xibosignage xibo-cms: from 1.8.0 before 2.3.17; from 3.0.0 before 3.3.5 — fixed in 2.3.17, 3.3.5
How to fix
Upgrade to a fixed version: xibosignage xibo-cms 2.3.17, 3.3.5. Check the vendor advisory for mitigations.
References
- https://claroty.com/team82/disclosure-dashboard
- https://github.com/xibosignage/xibo-cms/commit/1cbba380fa751a00756e70d7b08b5c6646092658
- https://github.com/xibosignage/xibo-cms/commit/45c6b53c3978639db03b63270a56f4397f49b2c9
- https://github.com/xibosignage/xibo-cms/security/advisories/GHSA-jj27-x85q-crqv
- https://xibosignage.com/blog/security-advisory-2023-05/
- https://claroty.com/team82/disclosure-dashboard
- https://github.com/xibosignage/xibo-cms/commit/1cbba380fa751a00756e70d7b08b5c6646092658
- https://github.com/xibosignage/xibo-cms/commit/45c6b53c3978639db03b63270a56f4397f49b2c9
- https://github.com/xibosignage/xibo-cms/security/advisories/GHSA-jj27-x85q-crqv
- https://xibosignage.com/blog/security-advisory-2023-05/
Get alerted when CVE-2023-33177 or the next vulnerability affects your stack