What’s Vulnerable › Vulnerabilities
CVE-2023-33192: Improper handling of NTS cookie length that could crash the ntpd-rs server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-27 · updated 2026-06-17
- Weakness: CWE-130
Description
ntpd-rs is an NTP implementation written in Rust. ntpd-rs does not validate the length of NTS cookies in received NTP packets to the server. An attacker can crash the server by sending a specially crafted NTP packet containing a cookie shorter than what the server expects. The server also crashes when it is not configured to handle NTS packets. The issue was caused by improper slice indexing. The indexing operations were replaced by safer alternatives that do not crash the ntpd-rs server process but instead properly handle the error condition. A patch was released in version 0.3.3.
Affected products
- pendulum-project ntpd-rs: from 0.3.0 before 0.3.3 — fixed in 0.3.3
How to fix
Upgrade to a fixed version: pendulum-project ntpd-rs 0.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/pendulum-project/ntpd-rs/pull/752
- https://github.com/pendulum-project/ntpd-rs/security/advisories/GHSA-qwhm-h7v3-mrjx
- https://github.com/pendulum-project/ntpd-rs/pull/752
- https://github.com/pendulum-project/ntpd-rs/security/advisories/GHSA-qwhm-h7v3-mrjx
Get alerted when CVE-2023-33192 or the next vulnerability affects your stack