What’s Vulnerable › Vulnerabilities
CVE-2023-33194: CraftCMS stored XSS in Quick Post widget error message
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-26 · updated 2026-06-17
- Weakness: CWE-80
Description
Craft is a CMS for creating custom digital experiences on the web.The platform does not filter input and encode output in Quick Post validation error message, which can deliver an XSS payload. Old CVE fixed the XSS in label HTML but didn’t fix it when clicking save. This issue was patched in version 4.4.6.
Affected products
- craftcms cms: from 3.0.0 before 3.8.6; from 4.0.1 before 4.4.6 — fixed in 3.8.6, 4.4.6
- CrafterCMS: 4.0.0, 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3
How to fix
Upgrade to a fixed version: craftcms cms 3.8.6, 4.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/commit/9d0cd0bda7c8a830a3373f8c0f06943e519ac888
- https://github.com/craftcms/cms/releases/tag/4.4.6
- https://github.com/craftcms/cms/security/advisories/GHSA-3wxg-w96j-8hq9
- https://github.com/craftcms/cms/commit/9d0cd0bda7c8a830a3373f8c0f06943e519ac888
- https://github.com/craftcms/cms/releases/tag/4.4.6
- https://github.com/craftcms/cms/security/advisories/GHSA-3wxg-w96j-8hq9
Get alerted when CVE-2023-33194 or the next vulnerability affects your stack