What’s Vulnerable › Vulnerabilities
CVE-2023-33234: Apache Airflow CNCF Kubernetes Provider: KubernetesPodOperator RCE via connection configuration
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-30 · updated 2026-07-02
- Weakness: CWE-74
Description
Arbitrary code execution in Apache Airflow CNCF Kubernetes provider version 5.0.0 allows user to change xcom sidecar image and resources via Airflow connection. In order to exploit this weakness, a user would already need elevated permissions (Op or Admin) to change the connection object in this manner. Operators should upgrade to provider version 7.0.0 which has removed the vulnerability.
Affected products
- Apache Software Foundation Apache Airflow CNCF Kubernetes provider: from 5.0.0 before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow CNCF Kubernetes provider 7.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/n1vpgl6h2qsdm52o9m2tx1oo86tl4gnq
- https://lists.apache.org/thread/n1vpgl6h2qsdm52o9m2tx1oo86tl4gnq
Get alerted when CVE-2023-33234 or the next vulnerability affects your stack