What’s Vulnerable › Vulnerabilities

CVE-2023-33265

Description

In Hazelcast through 5.0.4, 5.1 through 5.1.6, and 5.2 through 5.2.3, executor services don't check client permissions properly, allowing authenticated users to execute tasks on members without the required permissions granted.

Affected products

How to fix

Upgrade to a fixed version: hazelcast 5.0.5, 5.1.7, 5.2.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-33265 or the next vulnerability affects your stack