What’s Vulnerable › Vulnerabilities
CVE-2023-33285
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-22 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in Qt 5.x before 5.15.14, 6.x before 6.2.9, and 6.3.x through 6.5.x before 6.5.1. QDnsLookup has a buffer over-read via a crafted reply from a DNS server.
Affected products
- Qt: from 5.0.0 before 5.15.4; from 6.0.0 before 6.2.9; from 6.3.0 before 6.5.1 — fixed in 5.15.4, 6.2.9, 6.5.1
How to fix
Upgrade to a fixed version: Qt 5.15.4, 6.2.9, 6.5.1. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/qtbase/+/477644
- https://lists.debian.org/debian-lts-announce/2024/04/msg00027.html
- https://codereview.qt-project.org/c/qt/qtbase/+/477644
- https://lists.debian.org/debian-lts-announce/2024/04/msg00027.html
Get alerted when CVE-2023-33285 or the next vulnerability affects your stack