What’s Vulnerable › Vulnerabilities
CVE-2023-33466
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-29 · updated 2026-06-17
- Weakness: CWE-94
Description
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite arbitrary files on the file system, and in specific deployment scenarios allows the attacker to overwrite the configuration, which can be exploited to trigger Remote Code Execution (RCE).
Affected products
- orthanc-server orthanc: before 1.12.0 — fixed in 1.12.0
How to fix
Upgrade to a fixed version: orthanc-server orthanc 1.12.0. Check the vendor advisory for mitigations.
References
- https://discourse.orthanc-server.org/t/security-advisory-for-orthanc-deployments-running-versions-before-1-12-0/3568
- https://lists.debian.org/debian-lts-announce/2023/09/msg00009.html
- https://www.debian.org/security/2023/dsa-5473
- https://discourse.orthanc-server.org/t/security-advisory-for-orthanc-deployments-running-versions-before-1-12-0/3568
- https://lists.debian.org/debian-lts-announce/2023/09/msg00009.html
- https://www.debian.org/security/2023/dsa-5473
Get alerted when CVE-2023-33466 or the next vulnerability affects your stack