What’s Vulnerable › Vulnerabilities
CVE-2023-3348: Directory traversal vulnerability in Cloudflare Wrangler
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-03 · updated 2026-06-17
- Weakness: CWE-22
Description
The Wrangler command line tool (<=wrangler@3.1.0 or <=wrangler@2.20.1) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server.
Affected products
- Cloudflare Wrangler: before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Cloudflare Wrangler 3.1.1. Check the vendor advisory for mitigations.
References
- https://developers.cloudflare.com/workers/wrangler/
- https://github.com/cloudflare/workers-sdk
- https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-8c93-4hch-xgxp
- https://developers.cloudflare.com/workers/wrangler/
- https://github.com/cloudflare/workers-sdk
- https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-8c93-4hch-xgxp
Get alerted when CVE-2023-3348 or the next vulnerability affects your stack