What’s Vulnerable › Vulnerabilities
CVE-2023-3362: Generation of Error Message Containing Sensitive Information in GitLab
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-13 · updated 2026-06-17
- Weakness: CWE-209
Description
An information disclosure issue in GitLab CE/EE affecting all versions from 16.0 prior to 16.0.6, and version 16.1.0 allows unauthenticated actors to access the import error information if a project was imported from GitHub.
Affected products
- GitLab: from 16.0.0 before 16.0.6; 16.1.0 — fixed in 16.0.6
How to fix
Upgrade to a fixed version: GitLab 16.0.6. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/415131
- https://gitlab.com/gitlab-org/gitlab/-/issues/415131
Get alerted when CVE-2023-3362 or the next vulnerability affects your stack