What’s Vulnerable › Vulnerabilities
CVE-2023-3372: Lana Shortcodes < 1.2.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Lana Shortcodes WordPress plugin before 1.2.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which allows users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Lana Shortcodes: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: Lana Shortcodes 1.2.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3396b734-9a10-4070-802d-f9d01cc6eb74/
- https://wpscan.com/vulnerability/3396b734-9a10-4070-802d-f9d01cc6eb74/
Get alerted when CVE-2023-3372 or the next vulnerability affects your stack