What’s Vulnerable › Vulnerabilities
CVE-2023-33846: IBM CICS TX cross-site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM TXSeries for Multiplatforms 8.1, 8.2, 9.1, CICS TX Standard, 11.1, CICS TX Advanced 10.1, and 11.1 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 257100.
Affected products
- IBM CICS TX Advanced: 10.1, 11.1
- IBM Txseries For Multiplatform: from 8.2 before 8.2.0.2; from 9.1 before 9.1.0.2; 8.1 — fixed in 8.2.0.2, 9.1.0.2
How to fix
Upgrade to a fixed version: IBM Txseries For Multiplatform 8.2.0.2, 9.1.0.2. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/257100
- https://www.ibm.com/support/pages/node/7001601
- https://www.ibm.com/support/pages/node/7001629
- https://www.ibm.com/support/pages/node/7001633
- https://exchange.xforce.ibmcloud.com/vulnerabilities/257100
- https://www.ibm.com/support/pages/node/7001601
- https://www.ibm.com/support/pages/node/7001629
- https://www.ibm.com/support/pages/node/7001633
Get alerted when CVE-2023-33846 or the next vulnerability affects your stack