What’s Vulnerable › Vulnerabilities
CVE-2023-33963: DataEase data source has deserialization vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-01 · updated 2026-06-17
- Weakness: CWE-502
Description
DataEase is an open source data visualization and analysis tool. Prior to version 1.18.7, a deserialization vulnerability exists in the DataEase datasource, which can be exploited to execute arbitrary code. The vulnerability has been fixed in v1.18.7. There are no known workarounds aside from upgrading.
Affected products
- dataease: before 1.18.7 — fixed in 1.18.7
How to fix
Upgrade to a fixed version: dataease 1.18.7. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/releases/tag/v1.18.7
- https://github.com/dataease/dataease/security/advisories/GHSA-m26j-gh4m-xh9f
- https://github.com/dataease/dataease/releases/tag/v1.18.7
- https://github.com/dataease/dataease/security/advisories/GHSA-m26j-gh4m-xh9f
Get alerted when CVE-2023-33963 or the next vulnerability affects your stack