What’s Vulnerable › Vulnerabilities
CVE-2023-33966: Deno missing "--allow-net" permission check for built-in Node modules
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-31 · updated 2026-06-17
- Weakness: CWE-269
Description
Deno is a runtime for JavaScript and TypeScript. In deno 1.34.0 and deno_runtime 0.114.0, outbound HTTP requests made using the built-in `node:http` or `node:https` modules are incorrectly not checked against the network permission allow list (`--allow-net`). Dependencies relying on these built-in modules are subject to the vulnerability too. Users of Deno versions prior to 1.34.0 are unaffected. Deno Deploy users are unaffected. This problem has been patched in Deno v1.34.1 and deno_runtime 0.114.1 and all users are recommended to update to this version. No workaround is available for this issue.
Affected products
- denoland deno: 1.34.0
- Deno Runtime: 0.114.0
References
- https://github.com/denoland/deno/releases/tag/v1.34.1
- https://github.com/denoland/deno/security/advisories/GHSA-vc52-gwm3-8v2f
- https://github.com/denoland/deno/releases/tag/v1.34.1
- https://github.com/denoland/deno/security/advisories/GHSA-vc52-gwm3-8v2f
Get alerted when CVE-2023-33966 or the next vulnerability affects your stack