What’s Vulnerable › Vulnerabilities
CVE-2023-33967: EaseProbe vulnerable to SQL injection when using MySQL/PostgreSQL data checking
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-31 · updated 2026-06-17
- Weakness: CWE-89
Description
EaseProbe is a tool that can do health/status checking. An SQL injection issue was discovered in EaseProbe before 2.1.0 when using MySQL/PostgreSQL data checking. This problem has been fixed in v2.1.0.
Affected products
- MegaEase EaseProbe: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: MegaEase EaseProbe 2.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/megaease/easeprobe/commit/caaf5860df2aaa76acd29bc40ec9a578d0b1d6e1
- https://github.com/megaease/easeprobe/pull/330
- https://github.com/megaease/easeprobe/releases/tag/v2.1.0
- https://github.com/megaease/easeprobe/security/advisories/GHSA-4c32-w6c7-77x4
- https://github.com/megaease/easeprobe/commit/caaf5860df2aaa76acd29bc40ec9a578d0b1d6e1
- https://github.com/megaease/easeprobe/pull/330
- https://github.com/megaease/easeprobe/releases/tag/v2.1.0
- https://github.com/megaease/easeprobe/security/advisories/GHSA-4c32-w6c7-77x4
Get alerted when CVE-2023-33967 or the next vulnerability affects your stack