What’s Vulnerable › Vulnerabilities
CVE-2023-33976: TensorFlow segfault in array_ops.upper_bound
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-190
Description
TensorFlow is an end-to-end open source platform for machine learning. `array_ops.upper_bound` causes a segfault when not given a rank 2 tensor. The fix will be included in TensorFlow 2.13 and will also cherrypick this commit on TensorFlow 2.12.
Affected products
- tensorflow: before 2.13.0 — fixed in 2.13.0
How to fix
Upgrade to a fixed version: tensorflow 2.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/6fa05df43b00038b048f4f0e51ef522da6532fec
- https://github.com/tensorflow/tensorflow/commit/915884fdf5df34aaedd00fc6ace33a2cfdefa586
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gjh7-xx4r-x345
- https://github.com/tensorflow/tensorflow/commit/6fa05df43b00038b048f4f0e51ef522da6532fec
- https://github.com/tensorflow/tensorflow/commit/915884fdf5df34aaedd00fc6ace33a2cfdefa586
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gjh7-xx4r-x345
Get alerted when CVE-2023-33976 or the next vulnerability affects your stack