What’s Vulnerable › Vulnerabilities
CVE-2023-33979: gpt_academic's Configuration File vulnerable to File Information Disclosure
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-31 · updated 2026-06-17
- Weakness: CWE-200
Description
gpt_academic provides a graphical interface for ChatGPT/GLM. A vulnerability was found in gpt_academic 3.37 and prior. This issue affects some unknown processing of the component Configuration File Handler. The manipulation of the argument file leads to information disclosure. Since no sensitive files are configured to be off-limits, sensitive information files in some working directories can be read through the `/file` route, leading to sensitive information leakage. This affects users that uses file configurations via `config.py`, `config_private.py`, `Dockerfile`. A patch is available at commit 1dcc2873d2168ad2d3d70afcb453ac1695fbdf02. As a workaround, one may use environment variables instead of `config*.py` files to configure this project, or use docker-compose installation to configure this project.
Affected products
- binary-husky/gpt_academic: before 3.37 — fixed in 3.37
How to fix
Upgrade to a fixed version: binary-husky/gpt_academic 3.37. Check the vendor advisory for mitigations.
References
- https://github.com/binary-husky/gpt_academic/commit/1dcc2873d2168ad2d3d70afcb453ac1695fbdf02
- https://github.com/binary-husky/gpt_academic/security/advisories/GHSA-pg65-p24m-wf5g
- https://github.com/binary-husky/gpt_academic/commit/1dcc2873d2168ad2d3d70afcb453ac1695fbdf02
- https://github.com/binary-husky/gpt_academic/security/advisories/GHSA-pg65-p24m-wf5g
Get alerted when CVE-2023-33979 or the next vulnerability affects your stack