What’s Vulnerable › Vulnerabilities

CVE-2023-3399: Insertion of Sensitive Information Into Sent Data in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 11.6 before 16.3.6, all versions starting from 16.4 before 16.4.2, all versions starting from 16.5 before 16.5.1. It was possible for an unauthorised project or group member to read the CI/CD variables using the custom project templates.

Affected products

How to fix

Upgrade to a fixed version: GitLab 12.10.7, 12.9.8; GitLab 16.3.6, 16.4.2, 16.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-3399 or the next vulnerability affects your stack