What’s Vulnerable › Vulnerabilities

CVE-2023-3401: Improper Control of Generation of Code ('Code Injection') in GitLab

Description

An issue has been discovered in GitLab affecting all versions before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. The main branch of a repository with a specially designed name allows an attacker to create repositories with malicious code.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.0.8, 16.1.3, 16.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-3401 or the next vulnerability affects your stack