What’s Vulnerable › Vulnerabilities
CVE-2023-34034
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-19 · updated 2026-06-17
- Weakness: CWE-281
Description
Using "**" as a pattern in Spring Security configuration for WebFlux creates a mismatch in pattern matching between Spring Security and Spring WebFlux, and the potential for a security bypass.
Affected products
- Spring Security: from 5.6.0 before 5.6.12; from 5.7.0 before 5.7.10; from 5.8.0 before 5.8.5; from 6.0.0 before 6.0.5; from 6.1.0 before 6.1.2 — fixed in 5.6.12, 5.7.10, 5.8.5, 6.0.5, 6.1.2
- Spring Security: from Spring Security 6.1.0 through 6.1.1; from Spring Security 6.0.0 through 6.0.4; from Spring Security 5.8.0 through 5.8.4; from Spring Security 5.7.0 through 5.7.9; from Spring Security 5.6.0 through 5.6.11
How to fix
Upgrade to a fixed version: Spring Security 5.6.12, 5.7.10, 5.8.5, 6.0.5. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20230814-0008/
- https://spring.io/security/cve-2023-34034
- https://security.netapp.com/advisory/ntap-20230814-0008/
- https://spring.io/security/cve-2023-34034
Get alerted when CVE-2023-34034 or the next vulnerability affects your stack