What’s Vulnerable › Vulnerabilities
CVE-2023-34040: Java Deserialization vulnerability in Spring-Kafka When Improperly Configured
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-24 · updated 2026-06-17
- Weakness: CWE-502
Description
In Spring for Apache Kafka 3.0.9 and earlier and versions 2.9.10 and earlier, a possible deserialization attack vector existed, but only if unusual configuration was applied. An attacker would have to construct a malicious serialized object in one of the deserialization exception record headers. Specifically, an application is vulnerable when all of the following are true: * The user does not configure an ErrorHandlingDeserializer for the key and/or value of the record * The user explicitly sets container properties checkDeserExWhenKeyNull and/or checkDeserExWhenValueNull container properties to true. * The user allows untrusted sources to publish to a Kafka topic By default, these properties are false, and the container only attempts to deserialize the headers if an ErrorHandlingDeserializer is configured. The ErrorHandlingDeserializer prevents the vulnerability by removing any such malicious headers before processing the record.
Affected products
- Spring for Apache Kafka: from 2.8.1 through 2.9.10; from 3.0.0 through 3.0.9
- Spring for Apache Kafka: from 2.8.x before 2.9.11; from 2.9.x before 2.9.11; from 3.0.x before 3.0.10 — fixed in 2.9.11, 3.0.10
How to fix
Upgrade to a fixed version: Spring for Apache Kafka 2.9.11, 3.0.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-34040 or the next vulnerability affects your stack