What’s Vulnerable › Vulnerabilities
CVE-2023-34048: VMware vCenter Server Out-of-Bounds Write Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-01-22
- EPSS: 99.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-787
Description
vCenter Server contains an out-of-bounds write vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may trigger an out-of-bounds write potentially leading to remote code execution.
Affected products
- VMware vCenter Server: from 4.0 through 5.5; 7.0, 7.0-a, 7.0-b, 7.0-c, 7.0-d, 7.0-update1 (+30)
- VMware Cloud Foundation: from 4.0 before KB88287 — fixed in KB88287
- VMware vCenter Server: from 7.0 before 7.0U3o — fixed in 7.0U3o
- VMware vCenter Server: from 8.0 before 8.0U2; from 7.0 before 7.0U3o — fixed in 8.0U2, 7.0U3o
- VMware Cloud Foundation (VMware vCenter Server): 5.x, 4.x
How to fix
Upgrade to a fixed version: VMware Cloud Foundation KB88287; VMware vCenter Server 7.0U3o; VMware vCenter Server 8.0U2, 7.0U3o. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2023-0023.html
- https://www.vicarius.io/vsociety/posts/understanding-cve-2023-34048-a-zero-day-out-of-bound-write-in-vcenter-server
- https://www.vmware.com/security/advisories/VMSA-2023-0023.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-34048
Get alerted when CVE-2023-34048 or the next vulnerability affects your stack