What’s Vulnerable › Vulnerabilities
CVE-2023-34050: Spring AMQP Deserialization Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-19 · updated 2026-06-17
- Weakness: CWE-502
Description
In spring AMQP versions 1.0.0 to 2.4.16 and 3.0.0 to 3.0.9 , allowed list patterns for deserializable class names were added to Spring AMQP, allowing users to lock down deserialization of data in messages from untrusted sources; however by default, when no allowed list was provided, all classes could be deserialized. Specifically, an application is vulnerable if * the SimpleMessageConverter or SerializerMessageConverter is used * the user does not configure allowed list patterns * untrusted message originators gain permissions to write messages to the RabbitMQ broker to send malicious content
Affected products
- Spring AMQP: from 1.0.0 before 2.4.16; from 3.0.0 before 3.0.9 — fixed in 2.4.16, 3.0.9
- Spring AMQP: from 1.0.0 before 2.4.17; from 3.0.0 before 3.0.10 — fixed in 2.4.17, 3.0.10
How to fix
Upgrade to a fixed version: Spring AMQP 2.4.16, 3.0.9; Spring AMQP 2.4.17, 3.0.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-34050 or the next vulnerability affects your stack