What’s Vulnerable › Vulnerabilities
CVE-2023-34054: Reactor Netty HTTP Server Metrics DoS Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-28 · updated 2026-09-04
Description
In Reactor Netty HTTP Server, versions 1.1.x prior to 1.1.13 and versions 1.0.x prior to 1.0.39, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable if Reactor Netty HTTP Server built-in integration with Micrometer is enabled.
Affected products
- Spring Reactor Netty: before 1.0.39; from 1.1.0 before 1.1.13 — fixed in 1.0.39, 1.1.13
How to fix
Upgrade to a fixed version: Spring Reactor Netty 1.0.39, 1.1.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-34054 or the next vulnerability affects your stack