What’s Vulnerable › Vulnerabilities
CVE-2023-34055: Spring Boot server Web Observations DoS Vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-28 · updated 2026-06-17
Description
In Spring Boot versions 2.7.0 - 2.7.17, 3.0.0-3.0.12 and 3.1.0-3.1.5, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable when all of the following are true: * the application uses Spring MVC or Spring WebFlux * org.springframework.boot:spring-boot-actuator is on the classpath
Affected products
- Spring Boot: from 2.7.0 through 2.7.17; from 3.0.0 through 3.0.12; from 3.1.0 through 3.1.5
- Spring Boot: from 2.7.0 before 2.7.18; from 3.0.0 before 3.0.13; from 3.1.0 before 3.1.6; older unsupported versions — fixed in 2.7.18, 3.0.13, 3.1.6
How to fix
Upgrade to a fixed version: Spring Boot 2.7.18, 3.0.13, 3.1.6. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20231221-0010/
- https://spring.io/security/cve-2023-34055
- https://security.netapp.com/advisory/ntap-20231221-0010/
- https://spring.io/security/cve-2023-34055
Get alerted when CVE-2023-34055 or the next vulnerability affects your stack