What’s Vulnerable › Vulnerabilities
CVE-2023-34056: VMware vCenter Server Partial Information Disclosure Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-922
Description
vCenter Server contains a partial information disclosure vulnerability. A malicious actor with non-administrative privileges to vCenter Server may leverage this issue to access unauthorized data.
Affected products
- VMware vCenter Server: from 4.0 through 5.5; 7.0, 7.0-a, 7.0-b, 7.0-c, 7.0-d, 7.0-update1 (+31)
- VMware vCenter Server: from 8.0 before 8.0U2; from 7.0 before 7.0U3o — fixed in 8.0U2, 7.0U3o
- VMware Cloud Foundation (VMware vCenter Server): 5.x, 4.x
How to fix
Upgrade to a fixed version: VMware vCenter Server 8.0U2, 7.0U3o. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2023-0023.html
- https://www.vmware.com/security/advisories/VMSA-2023-0023.html
Get alerted when CVE-2023-34056 or the next vulnerability affects your stack