What’s Vulnerable › Vulnerabilities
CVE-2023-34057
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-27 · updated 2026-06-17
- Weakness: CWE-269
Description
VMware Tools contains a local privilege escalation vulnerability. A malicious actor with local user access to a guest virtual machine may elevate privileges within the virtual machine.
Affected products
- VMware Tools: from 10.3.0 before 12.1.1 — fixed in 12.1.1
- VMware Tools: 12.x.x, 11.x.x, 10.3.x
How to fix
Upgrade to a fixed version: VMware Tools 12.1.1. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2023-0024.html
- https://www.vmware.com/security/advisories/VMSA-2023-0024.html
Get alerted when CVE-2023-34057 or the next vulnerability affects your stack