What’s Vulnerable › Vulnerabilities
CVE-2023-34060
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-14 · updated 2026-06-17
- Weakness: CWE-306
Description
VMware Cloud Director Appliance contains an authentication bypass vulnerability in case VMware Cloud Director Appliance was upgraded to 10.5 from an older version. On an upgraded version of VMware Cloud Director Appliance 10.5, a malicious actor with network access to the appliance can bypass login restrictions when authenticating on port 22 (ssh) or port 5480 (appliance management console) . This bypass is not present on port 443 (VCD provider and tenant login). On a new installation of VMware Cloud Director Appliance 10.5, the bypass is not present. VMware Cloud Director Appliance is impacted since it uses an affected version of sssd from the underlying Photon OS. The sssd issue is no longer present in versions of Photon OS that ship with sssd-2.8.1-11 or higher (Photon OS 3) or sssd-2.8.2-9 or higher (Photon OS 4 and 5).
Affected products
- VMware Cloud Director Appliance (VCD Appliance): before 10.5 — fixed in 10.5
- VMware Cloud Director Appliance (VCD Appliance): 10.5 if upgraded from 10.4.x or below.
How to fix
Upgrade to a fixed version: VMware Cloud Director Appliance (VCD Appliance) 10.5. Check the vendor advisory for mitigations.
References
- https://github.com/vmware/photon/wiki/Security-Update-3.0-687
- https://github.com/vmware/photon/wiki/Security-Update-4.0-512
- https://github.com/vmware/photon/wiki/Security-Update-5.0-143
- https://www.vmware.com/security/advisories/VMSA-2023-0026.html
- https://github.com/vmware/photon/wiki/Security-Update-3.0-687
- https://github.com/vmware/photon/wiki/Security-Update-4.0-512
- https://github.com/vmware/photon/wiki/Security-Update-5.0-143
- https://www.vmware.com/security/advisories/VMSA-2023-0026.html
Get alerted when CVE-2023-34060 or the next vulnerability affects your stack