What’s Vulnerable › Vulnerabilities

CVE-2023-34062

Description

In Reactor Netty HTTP Server, versions 1.1.x prior to 1.1.13 and versions 1.0.x prior to 1.0.39, a malicious user can send a request using a specially crafted URL that can lead to a directory traversal attack. Specifically, an application is vulnerable if Reactor Netty HTTP Server is configured to serve static resources.

Affected products

How to fix

Upgrade to a fixed version: Spring Reactor Netty 1.0.39, 1.1.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-34062 or the next vulnerability affects your stack