What’s Vulnerable › Vulnerabilities
CVE-2023-34089: Decidim Cross-site Scripting vulnerability in the processes filter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in version 0.27.3 and 0.26.7.
Affected products
- decidim: before 0.26.7; from 0.27.0 before 0.27.3 — fixed in 0.26.7, 0.27.3
How to fix
Upgrade to a fixed version: decidim 0.26.7, 0.27.3. Check the vendor advisory for mitigations.
References
- https://github.com/decidim/decidim/releases/tag/v0.26.6
- https://github.com/decidim/decidim/releases/tag/v0.27.3
- https://github.com/decidim/decidim/security/advisories/GHSA-5652-92r9-3fx9
- https://github.com/decidim/decidim/releases/tag/v0.26.6
- https://github.com/decidim/decidim/releases/tag/v0.27.3
- https://github.com/decidim/decidim/security/advisories/GHSA-5652-92r9-3fx9
Get alerted when CVE-2023-34089 or the next vulnerability affects your stack