What’s Vulnerable › Vulnerabilities
CVE-2023-3409: Bricks <= 1.8.1 - Cross-Site Request Forgery via reset_settings
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-06-17
- Weakness: CWE-352
Description
The Bricks theme for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.8.1. This is due to missing or incorrect nonce validation on the 'reset_settings' function. This makes it possible for unauthenticated attackers to reset the theme's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Bricks Builder Bricks: before 1.8.2 — fixed in 1.8.2
How to fix
Upgrade to a fixed version: Bricks Builder Bricks 1.8.2. Check the vendor advisory for mitigations.
References
- https://bricksbuilder.io/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/16800ece-da9c-431b-a015-42bd30b646e2?source=cve
Get alerted when CVE-2023-3409 or the next vulnerability affects your stack