What’s Vulnerable › Vulnerabilities
CVE-2023-34098: Dependency configuration exposed in Shopware
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-27 · updated 2026-06-17
- Weakness: CWE-200
Description
Shopware is an open source e-commerce software. Due to an incorrect configuration in the `.htaccess` file, the configuration file of the Javascript could be read in production environments (`themes/package-lock.json`). With this information, the specific Shopware version in a deployment might be determined by an attacker, which could be used for further attacks. Users are advised to update to version 5.7.18. There are no known workarounds for this vulnerability.
Affected products
- shopware: from 5.6.0 before 5.7.18 — fixed in 5.7.18
How to fix
Upgrade to a fixed version: shopware 5.7.18. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2023
- https://github.com/shopware/shopware/security/advisories/GHSA-q97c-2mh3-pgw9
- https://github.com/shopware5/shopware/commit/b3518c8d9562a38615d638f31f79829f6e2f4b6a
- https://www.shopware.com/en/changelog-sw5/#5-7-18
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2023
- https://github.com/shopware/shopware/security/advisories/GHSA-q97c-2mh3-pgw9
- https://github.com/shopware5/shopware/commit/b3518c8d9562a38615d638f31f79829f6e2f4b6a
- https://www.shopware.com/en/changelog-sw5/#5-7-18
Get alerted when CVE-2023-34098 or the next vulnerability affects your stack