What’s Vulnerable › Vulnerabilities
CVE-2023-34105: SRS has command injection vulnerability in demonstration api-server for HTTP callback.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-12 · updated 2026-06-17
- Weakness: CWE-78
Description
SRS is a real-time video server supporting RTMP, WebRTC, HLS, HTTP-FLV, SRT, MPEG-DASH, and GB28181. Prior to versions 5.0.157, 5.0-b1, and 6.0.48, SRS's `api-server` server is vulnerable to a drive-by command injection. An attacker may send a request to the `/api/v1/snapshots` endpoint containing any commands to be executed as part of the body of the POST request. This issue may lead to Remote Code Execution (RCE). Versions 5.0.157, 5.0-b1, and 6.0.48 contain a fix.
Affected products
- ossrs Simple Realtime Server: from 5.0.137 before 5.0.157; from 6.0.18 before 6.0.48 — fixed in 5.0.157, 6.0.48
How to fix
Upgrade to a fixed version: ossrs Simple Realtime Server 5.0.157, 6.0.48. Check the vendor advisory for mitigations.
References
- https://github.com/ossrs/srs/blob/1d11d02e4b82fc3f37e4b048cff483b1581482c1/trunk/research/api-server/server.go#L761
- https://github.com/ossrs/srs/commit/1d878c2daaf913ad01c6d0bc2f247116c8050338
- https://github.com/ossrs/srs/security/advisories/GHSA-vpr5-779c-cx62
- https://github.com/ossrs/srs/blob/1d11d02e4b82fc3f37e4b048cff483b1581482c1/trunk/research/api-server/server.go#L761
- https://github.com/ossrs/srs/commit/1d878c2daaf913ad01c6d0bc2f247116c8050338
- https://github.com/ossrs/srs/security/advisories/GHSA-vpr5-779c-cx62
Get alerted when CVE-2023-34105 or the next vulnerability affects your stack