What’s Vulnerable › Vulnerabilities
CVE-2023-34110: Flask-AppBuilder vulnerable to possible disclosure of sensitive information on user error
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-22 · updated 2026-06-17
- Weakness: CWE-209
Description
Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.
Affected products
- Flask-Appbuilder Project Flask-Appbuilder: before 4.3.2 — fixed in 4.3.2
How to fix
Upgrade to a fixed version: Flask-Appbuilder Project Flask-Appbuilder 4.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/dpgaspar/Flask-AppBuilder/commit/ae25ad4c87a9051ebe4a4e8f02aee73232642626
- https://github.com/dpgaspar/Flask-AppBuilder/pull/2045
- https://github.com/dpgaspar/Flask-AppBuilder/releases/tag/v4.3.2
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-jhpr-j7cq-3jp3
- https://github.com/dpgaspar/Flask-AppBuilder/commit/ae25ad4c87a9051ebe4a4e8f02aee73232642626
- https://github.com/dpgaspar/Flask-AppBuilder/pull/2045
- https://github.com/dpgaspar/Flask-AppBuilder/releases/tag/v4.3.2
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-jhpr-j7cq-3jp3
Get alerted when CVE-2023-34110 or the next vulnerability affects your stack