What’s Vulnerable › Vulnerabilities
CVE-2023-3414: Cross-Site Request Forgery (CSRF) in Jenkins Plug-in for ServiceNow DevOps
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-26 · updated 2026-06-17
- Weakness: CWE-352
Description
A cross-site request forgery vulnerability exists in versions of the Jenkins Plug-in for ServiceNow DevOps prior to 1.38.1 that, if exploited successfully, could cause the unwanted exposure of sensitive information. To address this issue, apply the 1.38.1 version of the Jenkins plug-in for ServiceNow DevOps on your Jenkins server. No changes are required on your instances of the Now Platform.
Affected products
- ServiceNow Jenkins plug-in for ServiceNow DevOps: before 1.38.1 — fixed in 1.38.1
How to fix
Upgrade to a fixed version: ServiceNow Jenkins plug-in for ServiceNow DevOps 1.38.1. Check the vendor advisory for mitigations.
References
- https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB1434118
- https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB1434118
Get alerted when CVE-2023-3414 or the next vulnerability affects your stack