What’s Vulnerable › Vulnerabilities

CVE-2023-34140

Description

A buffer overflow vulnerability in the Zyxel ATP series firmware versions 4.32 through 5.36 Patch 2, USG FLEX series firmware versions 4.50 through 5.36 Patch 2, USG FLEX 50(W) series firmware versions 4.16 through 5.36 Patch 2, USG20(W)-VPN series firmware versions 4.16 through 5.36 Patch 2, VPN series firmware versions 4.30 through 5.36 Patch 2, NXC2500 firmware versions 6.10(AAIG.0) through 6.10(AAIG.3), and NXC5500 firmware versions 6.10(AAOS.0) through 6.10(AAOS.4), could allow an unauthenticated, LAN-based attacker to cause denial of service (DoS) conditions by sending a crafted request to the CAPWAP daemon.

Affected products

How to fix

Upgrade to a fixed version: Zyxel USG 20(W)-VPN firmware 5.37; Zyxel Usg 2200-Vpn Firmware 5.37; Zyxel firewall (ZLD) 5.37; Zyxel USG FLEX 100(W) firmware 5.37; Zyxel USG FLEX 200 firmware 5.37; Zyxel USG FLEX 500 firmware 5.37; Zyxel Usg Flex 50 Firmware 5.37; Zyxel USG FLEX 50(W) firmware 5.37; Zyxel USG FLEX 700 firmware 5.37; Zyxel Zywall Atp100 Firmware 5.37; Zyxel Zywall Atp100W Firmware 5.37; Zyxel Zywall Atp200 Firmware 5.37. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-34140 or the next vulnerability affects your stack